Introduction

The ftrack connect adobe plugins act as a bridge between the Adobe applications and ftrack. With the plugins into After Effects, Premiere and Photoshop you can easily share you work with others for review, and publish and import your files to ftrack.


Getting started

Getting started with the Adobe integration is really easy, just follow this guide and you will be up and running in no time.

1. Signup to ftrack (only for new users)

If you haven’t already got an ftrack account you can sign up for a 30 day free trial at our Sign up page.

2. Connect

Download and install ftrack Connect for your platform at Connect download page.

Open Connect and sign in with your company’s ftrack URL,
e.g. <company-url>.ftrackapp.com.

Note:
If this is the first time you use ftrack and Connect you will be asked to configure a Storage scenario to let ftrack now how to publish your files. See Configuring storage scenario for more information.

3. Adobe extension

Install the extension from Adobe Add-ons by searching for ftrack or navigating to the ftrack extension and pressing the Free button to install.

See also:
You can also install the extension manually using ZXP installer, see bottom of this article.


Start an Adobe CC application and click Window ‣ Extensions ‣ ftrack. This will open the ftrack panel. If Connect is running you should now be automatically connected to ftrack.


General workflows

This is describing generic workflows that may look and work slightly differently depending on which application you’re using. For application specific workflows see below.

Viewing your tasks

Staying up to date with your tasks and new assignments is essential for an easy collaboration. With the My tasks list you have easy access to your tasks and can change status, read notes and view what versions have been published to your tasks.

The My Tasks page shows you all tasks that are assigned to you but not yet completed.

Feedback

Communication and feedback is an important part of the day-to-day work. From the plugin you have easy access to all your notes.

To read notes on your tasks, select a task from My tasks. You can also browse other parts of the project to read and reply to notes.

On the notes page you can communicate with your fellow colleagues using Notes.

Quick review

With quick review it is easy to share your work with collaborators and external clients, to keep them up-to-date and get feedback on your work.

Choose quick review in the share menu, select your project and add collaborators. Then hit share to send out an email to the collaborators with a link to the review page.

From the review page collaborators will be able to reivew what you’ve shared, add feedback by drawing annotations or writing notes. When feedback has been added notifications are sent out via email to all collaborators to make sure nothing is missed.

Publish media

When you’re satisfied with your work and want to share it with your team you can choose to publish it.

Publishing something means that the material that you’re working will be saved and published as a Version to ftrack. This means that one or more files will be saved to disk or uploaded to ftrack where others can import and view them.

From the publish page you can choose to what you want to link your version to. It can be directly on a project, or if you work on something complex a folder, task or other object within a project.

You can also choose a type, if you want categorize what you’re publishing.

If are already versions published that matches your name and asset type, ftrack will automatically version up what you’ve published. So if there is already a Version named Overlay of type Upload, ftrack will create a new version of it; Overlay v002. This is great if you work iteratively with your team and collaborate.

Advanced:
To learn more about where your files goes, please read this article.

Import published material

Importing published material into your application is easy. Simply navigate to the object that you want to import from, click on the Versions tab and locate your version. Now click import and ftrack will list all file Components that you can import.


Photoshop

Share your work for review

The quick review feature allows you to upload and send your latest document to collaborators or team members directly from within Photoshop.

ftrack will automatically export your document as a JPEG image, upload it and notify the collaborators via email while you can continue working on your project. When feedback arrive you will be notified via email.

Choose quick review in the share menu, select your project and add collaborators. Then hit share to send out an email to the collaborators with a link to the review page. From the review page collaborators will be able to view the image and add feedback by drawing annotations or writing notes. When feedback has been added, notifications are sent out via email to all collaborators to make sure nothing is missed.

More information about quick reviews can be found in the general Workflows section above.

Publish your work

The publish feature lets you publish your work to ftrack so that it can be handed over to someone else or imported into another application such as Premiere Pro or After Effects.

Publishing in Photoshop will publish the current document as a copy so that you can continue working on your local copy. The document will also be exported as JPEG image which can be viewed from the ftrack web interface.

More information about publishing media can be found in the general Workflows section above.

Import published files

Files that have been published as versions in ftrack can be imported into Photoshop. When selecting import on a version you are presented with a list of available files that can be imported. Importing a file in Photoshop is similar to using Open from the File menu.

More information about importing published material can be found in the general Workflows section above.

Note:
If a file is unavailable for import it means that it is not available in a storage that you are able to read from.



Premiere Pro

Share your work for review

The quick review feature allows you to upload and send your latest video to collaborators or team members directly from within Premiere Pro.

ftrack will automatically encode and upload the video and notify the collaborators via email while you can continue working on your project. When feedback arrive you will be notified via email.

Choose quick review in the share menu, select your project and add collaborators. Then hit share to send out an email to the collaborators with a link to the review page. From the review page collaborators will be able to play the video and add feedback by drawing annotations or writing notes. When feedback has been added, notifications are sent out via email to all collaborators to make sure nothing is missed.

More information about quick reviews can be found in the general Workflows section above.

Publish your work

The publish feature lets you publish your work to ftrack so that it can be handed over to someone else or imported into another application such as Photoshop or After Effects.

When publishing from Premiere Pro you can include the following:

  • The current project file.
  • An encoded export of the active sequence.
  • A capture of the current frame, which is used as a thumbnail.

More information about publishing media can be found in the general Workflows section above.

Import published files

Files that have been published as versions in ftrack can be imported into Premiere Pro. When selecting import on a version you are presented with a list of available files that can be imported. Importing a file in Premiere Pro is similar to using Import from the File menu.

More information about importing published material can be found in the general Workflows section above.

Note:
If a file is unavailable for import it means that it is not available in a storage that you are able to read from.



After Effects

Publish your work

The publish feature lets you publish your work to ftrack so that it can be handed over to someone else or imported into another application such as Photoshop or Premiere Pro.

When publishing from After Effects you can include the following:

  • The current project file.
  • An encoded export of a composition.
  • A capture of the current frame, which is used as a thumbnail.

More information about publishing media can be found in the general Workflows section above.

Import published files

Files that have been published as versions in ftrack can be imported into After Effects. When selecting import on a version you are presented with a list of available files that can be imported. Importing a file in After Effects is similar to using Import from the File menu.

More information about importing published material can be found here.

Note
If a file is unavailable for import it means that it is not available in a storage that you are able to read from.



Advanced

Manual installation

If you are having trouble installing the extension from Adobe Add-ons, you can install the extension using ZXP installer, a third-party installer for ZXP extension packages. Read more and download at zxpinstaller.com.

Download the Adobe extension from the ftrack Integrations page. Open ZXP Installer, locate the downloaded ZXP file and install it by dropping it on ZXP Installer.

Start Photoshop or Premiere and click Window ‣ Extensions ‣ ftrack. This will open the ftrack window. If Connect is running you should now be automatically connected to ftrack.

And that’s it!

Did this answer your question?