Introduction

The ftrack Connect Adobe integration act as a bridge between the Adobe applications and ftrack. With the integration into Photoshop, After Effects, and Premiere Pro you can easily share your work with others for review, and publish and import your files to ftrack.

Note: For the plugins to work you will need to have an ftrack account. Read more under Getting started below.

Getting started

Getting started with the Adobe integration is easy, just follow this guide and you will be up and running in no time.

  1. Sign up to ftrack (only for new users)
    If you haven’t already got an ftrack account you can sign up for a 30 day free trial at our sign up page.

  2. Connect
    Download, install and sign in to ftrack Connect by following this guide.

    Note: If this is the first time using ftrack with Connect, you will be asked to configure a Storage scenario to let ftrack know how to publish your files. See Configuring storage scenario for more information.

  3. Adobe extension
    Install the extension from Adobe Add-ons by searching for ftrack or navigating to the ftrack extension page and pressing the Free button to install.

    You can also install the extension manually using ZXP installer if you are having trouble installing it from Adobe Add-ons. Start by downloading the extension from the Adobe integration page. Open ZXP Installer, locate the downloaded ZXP file and install it by dropping it on the ZXP Installer interface.

Now start an Adobe CC application and click Window ‣ Extensions ‣ ftrack. This will open the ftrack panel. If Connect is running you should now be automatically connected to ftrack. And that's it!


View your tasks

Staying up to date with your tasks and new assignments is essential for an easy collaboration. With the My tasks list you have easy access to your tasks and can change status, read notes and view what versions have been published to your tasks.

The My Tasks list shows you all tasks that are assigned to you but not yet completed.


Feedback

Communication and feedback is an important part of the day-to-day work. From the integration you have easy access to all your notes.

To read notes on your tasks, select a task from My tasks. You can also browse other parts of the project to read and reply to notes.


Share your work for review

The quick review feature allows you to upload and send your latest media to collaborators or team members directly from within Premiere Pro and Photoshop. With quick review it is easy to share your work with collaborators and external clients, to keep them up-to-date and get feedback on your work.

Follow the steps below to share your media for review:

  1. Choose Quick review in the share menu, select your project and add collaborators.
  2. Then hit Share to send out an email to the collaborators with a link to the review page.
  3. From the review page collaborators will be able to playback the video, view the image, and add feedback by drawing annotations or writing notes.
  4. When feedback has been added, notifications are sent out via email to all collaborators to make sure nothing is missed.

ftrack Connect for Premiere Pro will automatically encode and upload the video and notify collaborators via email while you continue working on the project. 

ftrack Connect for Photoshop will automatically export your document as a JPEG image, upload it and notify the collaborators via email while you can continue working on your project. 


Publish your work

The publish feature lets you publish your work to ftrack so that it can be handed over to someone else or imported into another application such as Photoshop, After Effects, or Premiere Pro.

Publishing from Premiere Pro you can include the following:

  • The current project file.
  • An encoded export of the active sequence.
  • A capture of the current frame, which is used as a thumbnail.

Publishing in Photoshop includes the following:

  • The current project file as a copy so that you can continue working on your local copy.
  • The project will also be exported as JPEG image viewable from the ftrack web interface.

Publishing from After Effects you can include the following:

  • The current project file.
  • An encoded export of a composition.
  • A capture of the current frame, which is used as a thumbnail.

When you’re satisfied with your work and want to share it with your team you can choose to publish it.

What does Publishing mean in ftrack?

Publishing something means that the material that you’re working on will be saved and published as a Version to ftrack. This means that one or more files will be saved to disk or uploaded to ftrack where others can import and view them.

From the publish page you can choose what you want to link your version to. It can be directly on a project, or if you work on something complex as folder, task or other object within a project.

You can also choose a type if you want to categorize what you’re publishing.

If published versions matching your name and asset type exist, ftrack will automatically version up what you’ve published. For instance: A Version named Overlay with the type Upload has already been published to ftrack, when a new version is ready to submit the publisher will create Overlay v002. This is great if you work iteratively with your team and collaborate.

To learn more about where your files goes, please read this article.


Import published files

Files that have been published as versions in ftrack can be imported back into their native applications. When selecting import on a version you are presented with a list of available files that can be imported.

  • Importing a file in Premiere Pro is similar to using Import from the File menu.
  • Importing a file in Photoshop is similar to using Open from the File menu.
  • Importing a file in After Effects is similar to using Import from the File menu.

Note: If a file is unavailable for import it means that it is not available in a storage that you are able to read from.

Importing published material into your application is easy. First, navigate to the object that you want to import from, click on the Versions tab and locate your version. Then, click import and ftrack will list all file components that you can import.

Did this answer your question?